It's our 19th anniversary!

The supporting of trading platforms with build below 215 is stopped

Publication Date: July 1, 2009

Dear Customers!

We inform you that starting from July, 20, 2009 we stop supporting the trading terminals with build below 215.

We ask you to upgrade your terminal to the latest version in time. You can download the latest version on our web-site «Download MetaTrader 4».

The current version of your terminal you can know if go to menu «Help»->«About».

Regards,
Technical Support Service

Category: Site maintenance notifications

Mo
Tu
We
Th
Fr
Sa
Su
Wk
29
30
1
2
3
4
5
27
6
7
8
9
10
11
12
28
13
14
15
16
17
18
19
29
20
21
22
23
24
25
26
30
27
28
29
30
31
1
2
31
3
4
5
6
7
8
9
32

Back to top